chore(deps): admit rouge 5 + refresh the dogfood site's dependencies
Merged
MH
4mo ago+29+29+01234567890123456789-24-24-01234567890123456789
Summary
Follow-up from the 1.0.3 dogfood rollout: docs-kit's rouge >= 4.0, < 5 cap was silently downgrading consuming sites already on rouge 5.x (daisyui's docs app went 5.0.0 → 4.7.0 when it adopted the released gem).
| Change | Detail |
|---|---|
| rouge constraint | >= 4.0, < 5 → >= 4.0, < 6 — verified against the full component suite (736 examples, including the multi-lexer DocsUI::Code specs and the inline theme CSS) running rouge 5.0.0 |
| Dogfood gems | bundle update: rouge 5.0.0, daisyui 1.2.1, playwright-ruby-client 1.61.0 (+ strscan, rouge 5's new dep) |
| Dogfood node packages | bun update --latest: tailwindcss + @tailwindcss/cli 4.1.18 → 4.3.2, daisyui 5.6.0 → 5.6.13, playwright 1.50 → 1.61.1 |
All other gemspec runtime constraints already admit their latest versions (phlex-rails 2.4, rails_icons 1.9, commonmarker 2.8, nokogiri 1.19, zeitwerk 2.8) — no other widening needed.
Verification
- Gem suite against rouge 5.0.0 — 736 examples, 0 failures
-
bundle exec rubocop— no offenses - Dogfood CSS rebuilt clean (daisyUI 5.6.13 / tailwind 4.3.2)
- Docs suite — 15 examples, 0 failures, including the Playwright system specs on playwright 1.61
After merging
Release (e.g. rake release[1.0.4]) so consuming sites can bundle update docs-kit rouge and get rouge 5 back — daisyui is the one currently pinned down to 4.7.0 by this constraint.